Bob Hoffman
posted this on March 03, 2010 09:38
Possible Causes
Symptoms of Database Problems or Crashing:
Resolution:
Further Troubleshooting Steps
Remove Database Errors
It might be necessary to try a couple things to remove any database errors.
1st option: There are Database Utilities installed to automatically fix problems. First, run the Verify option, from Control > Database Utilities > Verify. This may correct some basic issues with the database. A more robust solution, if this does not work, is to Initialize the database, then Verify again. If you Initialize, all price data is erased, so you will need to download again. This is straightforward for anything with a good data vendor or backfill service, such as DTN MA, which we offer.
To Initialize, go to Control > Database Utilities > Initialize > Intraday Daily Weekly Monthly. Then after you complete this, you will need to repopulate your database, following these guidelines:
http://support.marketdelta.com/entries/114670
This process erases your price data, but keeps your charts and quotepages.
2nd option Full Database Initialization and Maintenance (non-destructive):
Database Initialization:
1.Check all databases within this category
-This includes Ticks & Bars, News, Trading Notes, Groups, Daily, Weekly, Monthly Bars, Portfolios
2. Click "Initialize Selected Database"
- A prompt to initialize each database will pop up. Proceed with clicking initialize for each database
Data Management:
1. Click "Delete Temporary Files"
2. Click Purge Historical Data"
Database Repair and Maintenace:
1. Click Full Maintenance
**After performing these steps, close MarketDelta and reopen. Database and symbol errors should now be corrected.**
3rd option: As a last resort, the entire database can be corrected by refreshing with an entirely new database. This will fix all errors with your current database, but it also erases all price data, so you will need to backfill your chart.
Before proceeding: you may wish to backup your charts and quote pages, unless you do not mind rebuilding them. You use can use the Object Editor to export charts if desired. If you need help backing up your charts, let us know before you proceed with the following.
You will also want to save your Quote Page(s). Use the Object Editor as well to export quote pages. Most importantly is the ".All Symbols" quote page, but you may also have custom quotes pages that you want to keep. If you do not export your quote pages, all you have to do is re-enter your symbols on the new quote page after the database is reset.
The following article discusses how to create a fresh database, in effect "resetting" the MarketDelta database system. This fixes all database errors, which may be causing program crashes and other problems:
http://support.marketdelta.com/entries/326361
Send us your archive
Any issues that pop up again as a result of an actual corrupt chart or other component that is creating database problems, even after a reset, can be diagnosed by looking at a database archive. Of particular benefit is to send us an archive of the entire program database (not including the actual price data). This will include all charts and other stored items that can cause the crash, and our developers can look into the file in search of the cause. When we've exhausted other efforts, this is an excellent troubleshooting method. To do this, click the Control menu, then Database Utilities, then Archive Database. A pop-up box will appear to which you must say "No" or else the resulting file will be too large to email us. Then choose the computer location to save the archive file, and then email us that file to support@marketdelta.com (or reply to an existing email on this subject).